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Getting up to speed
This file contains a short set of exercises for those who have not used Excel extensively and/

or recently, and covers some simple manipulations, such as entering data, making graphs, in-
stalling, activating, and using the Data Analysis ToolPak and Solver, installing the MacroBundle
and its toolbar, and using macros. If you are an experienced Excel user you may want to skip this
exercise altogether, or perhaps browse in it for some specific items. If you want to do some or all
of its exercises, it may be convenient for you to print this file first. 

1.  Open Excel, see what is there, and add what is needed 
1.1  What you will need 

Depending on how Excel was installed and subsequently configured, it may or may not have
all the things you need. Here is a list of what you will need:

Toolbars The standard and formatting toolbars are very useful while you 
work in Excel, and should always be displayed.

Data Analysis ToolPak This is a set of helpful macros provided by Microsoft and 
included on the installation disk, but not always activated. 

Solver Solver is a crucial macro, again included on the Excel 
 installation disk, but not always activated.
MacroBundle The custom macros included in this package were written 

specifically to accompany my book Advanced Excel for 
scientific data analysis.   

1.2  Configuring the toolbars 
Open Excel, click on the menu item View, then in the drop-down submenu click on Toolbars.

If not already done, checkmark the top two items in the toolbar list, ‘Standard’ and ‘Formatting’.
You can of course add any other toolbars you wish, but these two are the ones you will almost
always need. 

1.3  Checking (and if needed installing) the ToolPak and Solver 
Click on Tools, then find the items Solver and Data Analysis. If you see a chevron (two

nested v's) at the bottom of the submenu, click on it to look at the rest of the drop-down menu,
which is otherwise not displayed. If you see the above-mentioned items listed, you are in good
shape. If one or both is missing, stay in the Tools submenu, click on Add-Ins, and see whether
Analysis ToolPak and Solver Add-in are listed under Add-Ins available. If they are listed, select
them by clicking on the boxes to the left of their names, which will then show a checkmark.
(And while you're at it, also activate Analysis ToolPak - VBA). That should do it. If one or both
is not listed, you will first need to get the original installation disk, and add these features using
the sequence Start ⇒ Settings ⇒ Control Panel ⇒ Add/Remove Programs. Then make sure that
both are displayed in the Tools ⇒ Add-Ins listing, and are activated.
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1.4  Installing the MacroBundle 
The MacroBundle is not part of Excel, and therefore must always be installed. Here is how to

do that. Highlight its entire text (e.g., with Edit ⇒ Select All) and then copy this onto the clip-
board, e.g. with Ctrl∪c, i.e., by depressing the Control key and simultaneously, with another fin-
ger, the key for c). You can now leave (or even close) the Word file containing the MacroBundle
because you will not need it any more.

Open Excel, and use either Alt∪F11 (i.e., simultaneously depressing the Alternate and F11
function keys; on a Mac use Opt∪F11 instead) or the sequence Tools ⇒ Macro ⇒ Visual Basic
Editor, then in the resulting Microsoft Visual Basic menu bar click on Insert ⇒ Module, and fi-
nally paste the MacroBundle with, e.g., Ctrl∪v. If you already have macros in a module, open the
module with Alt∪F11 (or Opt∪F11 on the Mac), go to the end of your macros, then paste the
MacroBundle below the already existing macros. The text file you have just pasted in will ac-
quire colors: green for comments, blue for key words, and hopefully no red for errors. The col-
oring assures you that the macros are indeed recognized as such by the Visual Basic Editor. 

You have now installed all the custom macros of the MacroBundle in a place where Excel ex-
pects and can use them. If you want to see an alphabetical listing of all available macros, look in
the dialog box with Alt∪F8 (Opt∪F8 on the Mac) or under Tools ⇒ Macro ⇒ Macros. Note that
these macros will be saved as part of the spreadsheet when you save the latter, but will only be
available when this particular spreadsheet is open. There are ways to make sure that the macros
are always available, whatever Excel spreadsheet you open, but for now it will do to have them
available here, in what most likely is called Book1.

1.5  Installing the MacroBundleToolbar 
To facilitate access to the macros in the MacroBundle (without every time having to use

Alt∪F8 (Mac: Opt∪F8) or Tools ⇒ Macro ⇒  Macros followed by double-clicking on the appro-
priate macro name) you may want to install the MacroBundle toolbar, which lets you select a
macro with one or two mouse clicks. In order to do so (now that the MacroBundle is installed),
use Alt∪F8 (Mac: Opt∪F8) or Tools ⇒ Macro ⇒ Macros, and in the resulting Macro dialog box
find and then double-click on InstallMBToolbar. (If you don't like it, you can always remove it
with RemoveMBToolbar.) Once you see how InstallMBToolbar works you will be able to add
your very own macros to this toolbar and/or remove macros from it that you don’t need.  

With the standard and formatting toolbars configured, the Data Analysis ToolPak and Solver
installed and activated, the MacroBundle copied into an Excel module, and the MacroBundle
toolbar mounted, you are ready to go. 

2.  Enter data & make a graph 
Start with a clean Excel worksheet in the workbook you have prepared as described in section

1, most likely called Book1 (as listed in the blue title bar), Sheet1 (look for this name on the tab
at the left bottom of the screen). In order to be able to see both names simultaneously, you may
have to click on the middle icon at the top right corner of the spreadsheet, so that the spreadsheet
fills the entire monitor screen. 
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2.1  Making labels 
Before we enter any data we will first make labels. (It is amazing how quickly one can forget

what unlabeled data mean.) If cell A1 is not activated (i.e., surrounded by a thick black frame),
move the pointer to cell A1 and click. Press the x key, then depress the Enter key (on the Mac,
the Return key). This will deposit the letter x in cell A1. Depressing the Enter (Mac: Return) key
is necessary to let the computer know that this is all the information you want to enter in this cell,
and that you were not, e.g., just starting to type xenon or xylophone.   

Go with the pointer to cell B1 and, in the same way, enter the letter y there. Go back with
your pointer to cell A1 and activate it by clicking on it without releasing the click but, while
keeping the mouse button down, move the pointer to cell B1. Only then release the mouse. Now
both cells A1 and B1 should be activated.

Move the pointer to the formatting toolbar, and place it over the icon B. (If you are not sure
what that icon does, keep the mouse pointer over the icon for a few seconds, and a small yellow
note describing its function will appear.) Click on the icon, and verify that the text in the acti-
vated cells will now be shown in boldface. Move the pointer to the right, to the icon I (for Italic),
and again click on it. Finally, move the pointer three more places to the right, to be over the cen-
ter icon, and click on it too. You have now made clearly distinguishable labels for the data to be
entered. 

2.2  Entering data 
Now we will enter some data. Go to cell A3 and enter the number 1. (Don't forget to use the

Enter key to close the deal.) Go to cell A4 (if Excel does not already went there for you in antici-
pation of your next move) and enter the number 2. Go back to cell A3, click on it without re-
leasing the mouse button, move the pointer to cell A4, then release the button.

Now that you have activated cells A3 and A4, move your pointer to the handle (the small
square in the bottom-right edge around the activated area) until it shows a thin cross. Then de-
press the mouse, drag it down till cell A10, then release the mouse button. This will enter the
numbers 3 through 8 in cells A5 through A10 respectively. 

Move the pointer to cell A13, and deposit a label specifying a number of decimals, such as
‘decimals:’ or ‘# of dec:’. In cell A14 deposit the number 0.

Activate cell B3, type =ROUND(10*A3/7,$A$14), and press Enter (Return for Mac users) to
deposit this instruction. The cell will compute the value of 10*A3/7 rounded to the number of
decimal places specified in cell A14, and will therefore show the numerical value 1. 

Stay at (or go back to) cell B3, double click (i.e., click twice in rapid succession; on the Mac,
use Ctrl∪click) on its handle to copy this instruction down alongside the data in column A. Alter-
natively (but slower) you can copy the instruction in cell B3 with Ctrl∪c, then highlight (i.e., ac-
tivate) cells B4:B10, and paste the instruction there with Ctrl∪v. Here we use the linking symbol
∪ to indicate that you must depress the linked symbols simultaneously to get the desired effect.  

2.3  Making a graph 
The next stage is to plot the data. Activate (highlight) the area A3:B10, i.e., the rectangular

block of which A3 is the top left-hand corner, and B10 the bottom right-hand corner. If you just
used the double-clicking method, all you have to do is to press the left-arrow key to add A3:A10
to the highlighted area. Otherwise, go (with the pointer) to cell A3, depress the mouse button,
move the pointer to B10, and release the button.
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Click on Insert in the standard toolbar, then in the drop-down menu click on Chart. In the re-
sulting Chart Wizard dialog box, under Chart type, click on XY(Scatter) but do not click on Line,
then click on Finish. If you wish you can go through the intermediate steps of the Chart Wizard,
but that is not needed for now; you can always modify the chart later. 

You will see a graph appear on the spreadsheet. It may not have the format you want (most
likely it will show horizontal grid lines and a gray background) but you can leave all embellish-
ments for later (when you are more comfortable with the spreadsheet and can follow your per-
sonal taste) or try out those listed in the next section.

2.4  Embellishing the graph 
We will make only a few modifications here. Once you see how they are made, you will have

no problem making others to create a graph to suit your own taste. In general it is good practice
to identify the input data clearly as experimental points (i.e., without connecting lines). We will
also label the axes, and simplify the graph. To accomplish the first, click on a data point once,
then right-click on it (on the Mac, press Ctrl∪click) to get a menu of properties, and in it click on
Format Data Series. Under the tab Patterns, in the right-hand column under Marker click on a
circle (the one-but-last item in the list; click on the down arrow in the Style box to find it), select
black as your Foreground color, No Color as your Background color, and 7 pts as your Size.
Since these are individual data points, don't connect them, i.e., in the left-hand column under
Line select None. Click OK. 

To label the axes you can click on the plot area (inside the inner graph frame), then select
Chart Options in the menu, and take it from there. Or you can click on the plot area, then click in
the wide window behind the equal sign in the formula bar, type x (or whatever text you want),
push Enter (Return on the Mac) , and end up with the text in a box in the plot area. Move the
pointer until it is over the text and shows as an I, depress the mouse button and move the pointer
over the text area to highlight that text, release the button and in the font box of the formatting
toolbar select a font (e.g., Times New Roman), font size (e.g., 12), Bold, Italic, etc. Thereafter
grab one of the box handles (the pointer will show as a double-faced arrow) to make the box fit
the text, and move the entire box to where you want it. Do the same with the label for the vertical
scale. 

To simplify the graph, click on the box with the Legend Series1, right-click on it (Ctrl∪click
on the Mac), and click on Clear. The graph will expand to use the space occupied earlier by the
legend box. To remove the horizontal grid lines, move your pointer to one of these lines until
you see a yellow box appear with text such as ‘Value (Y) Axis Major Gridlines’ (various ver-
sions of Excel may show slightly different texts), right-click on it (from now on, Mac users will
know what to do instead, so this will not be repeated) and Clear. Finally, click somewhere in the
graph (avoiding the data points), right-click, in the resulting menu box select Format Plot Area,
and select None under Area, then click OK. 

2.5  Moving and sizing the graph 
Move your pointer to the region between the right inner and outer graph frames, which after a

few seconds will be identified by the yellow label as Chart Area. Click on it, and a frame with
eight handles will appear. Holding down the mouse button, drag the entire graph with the
pointer. It as it were ‘floats’ above the spreadsheet, and by releasing the mouse button can be lo-
cated anywhere without erasing what is underneath it, although it temporarily blocks that area
from your view. Now move the pointer to one of the four corner handles and, after the pointer
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changes into a double-headed arrow, depress the mouse button and drag the corner to change the
graph size. Center the graph on the spreadsheet grid by depressing the Alt (Mac: Opt) key before
you release the pointer button. This makes it neater-looking and easier to copy into Word. Also
try out the handles in the middle of the individual sides. Finally, place your graph somewhere
(e.g., in the block H1:K20) where it does not obstruct your view of the data, or of columns that
you will use next.

3.  Fit the data with least squares 
3.1  Rearranging the data  

For making a graph it is simplest to have the dependent variable (here y) listed to the right of
the independent variable (x) because that is what the ChartWizard expects. For least squares fit-
ting of the data, the data should be organized just the other way around: y to the left, x to the
right. We therefore first rearrange the data. Highlight A1:A10, cut it with Ctrl∪x, move the
pointer to C1, and paste with Ctrl∪v. Note that this move does not affect the graph. 

3.2  Calling least squares  
 Excel contains three least squares routines: the self-updating function LinEst, the macro Re-

gression in the Data Analysis ToolPak, and the graphical TrendLine feature, and the book illus-
trates how they work. The MacroBundle provides a fourth option, the macro LS, which we will
use here. Highlight the area B3:C10 (i.e., only data, no headings), then click on LS in the Mac-
roBundle toolbar, and again on the submenu LS0. (When the MacroBundle toolbar is not yet in-
stalled, use Alt∪F8 or Tools ⇒ Macro ⇒  Macros followed by double-clicking on LS0.) In row
11 the macro will display the numerical value 1.422 (or as many decimal places as space allows)
of the coefficient a1 that best fits the expression y = a1x. The next row shows the associated stan-
dard deviation in a1 as s1 = 0.023, and the third row the standard deviation of the over-all fit, sy =
0.326. You might report your result as, e.g., a1 = 1.422 ± 0.023 with lowered guard digits (statis-
tically insignificant digits that might be useful to reduce round-off errors in further calculations).
If we had not rounded the data in column B we would have found a1 = 10/7 ≈ 1.4286.  

3.3  Plotting the least squares result  
 In order to see how good (or bad) this fit is, now compute and plot the function y = a1x with

a1 as found. In cell D1 place the label Ycalc, in cell D3 deposit the instruction =$C$11*C3, and
copy this instruction down to D4:D10. (If you use double-clicking on the handle of cell D3, the
column will extend to D12. In that case, delete the contents of cells D11:D13.) Highlight
D3:D10, copy it to the clipboard with Ctrl∪c, move the pointer to the central (plot) area of the
graph, click on it to activate it (its edge will be highlighted), then paste with Ctrl∪v. Bingo, the
curve of ycalc vs. x is now part of the graph. Clean it up by clicking plus right-clicking on the
newly imported data (which are most likely displayed in pugnacious pink), select Format Data
Series, Patterns, and display ycalc with, e.g., a medium-thickness line and no markers, clearly dis-
tinguishing the individual data points and the continuous function predicted to represent them.  

3.4  Adding imprecision contours  
You can also put some imprecision contours around that line. Here we will simply compute

curves indicating ± one standard deviation s, where s = √ (sy
2 + s0

2 x2). In cell E1 deposit the label
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s, and in cell E3 the instruction =SQRT($C$13^2+($C$12*C3)^2). Copy this instruction down
to E10. In cell F1 place the label ycalc–s, in cell F3 the instruction =D3–E3, copy this down to
cell F10, highlight F3:F10, copy it, highlight the plot area of the graph, and paste the lower limit
ycalc–s into the graph. Display it with a thin line. Now repeat the same with ycalc+s in column G.
You will now have a graph of the best-fitting proportionality through your ‘experimental’ points,
plus the associated imprecision band at ± one standard deviation. Your graph might now look
like Fig. 1.

Fig. 1. A graph of a proportionality through the data, with the data points (gray circles), the best-
fitting line through the origin, and (thinner) imprecision contours at ± one standard deviation.

3.5  Trying another model  
 So far we fitted the data to a proportionality, i.e., to a line through the origin. That was the

appropriate model to use, because the data had been generated with the proportionality y =
10x/7, which was then rounded to produce round-off ‘noise’ by using only the integer part of the
result. In general, with real data, we will not know whether to fit the data to a proportionality y =
a1x or to the more general line y = a0 + a1x, and we will therefore briefly explore the latter. 

Highlight B1:C10, copy it (e.g., with Ctrl∪c), then move your pointer to cell B15, activate that
cell, and paste (Ctrl∪v). This will duplicate the input data. Now highlight block B17:C24, and
call the macro LS1 (instead of LS0). Answer No to displaying the linear correlation coefficients.
You will now see the two coefficients a0 and a1 of the line y = a0 + a1x, (in cells B25 and C25
respectively), the corresponding standard deviations s0 and s1 in row 26, the standard deviation of
the fit sy in cell B27, and the covariance matrix (in color) in B28:C29. Spreadsheet magic, simply
with a few clicks! 

The result can be written as y = a0+a1x = (–0.11±0.27) + (1.440 ± 0.054) x. Note that the stan-
dard deviation of the intercept, s0 = 0. 27, is larger than the absolute value of that intercept, |a0| =
0.11, so that a0 does not differ significantly from zero. For these data, therefore, a proportionality
(rather than a general straight line) is indeed the correct fit. 

3.6  Changing the input data   
What if we change the input data to have less noise? Go to cell A14 and change its numerical

value to, say, 1. This will round the y-values in column B to one decimal place, i.e., to ±0.05.
The plot now shows the new input data, but the lines are still the old ones, because the macro
does not update itself. So, highlight block B3:C10 and call LS0 again. Allow it to overwrite the
earlier data by answering Yes to Overwrite? In the same sense, highlight B17:C24, and call LS1.
We now find y = (1.4275 ± 0.0021) x for LS0 and y = (0.007 ± 0.025) + (1.4262 ± 0.0050) x for
LS1, while 10/7 ≈ 1.4286. Again, the intercept is statistically insignificant because |a0| is much
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smaller than s0, so that the proper fit of these data is indeed to y = a1x rather than to y = a0 + a1x.
Note that, with ten times less noise, the imprecision contours at ± s are now quite close to ycalc
and may no longer be visible in the graph. 

3.7  Adding Gaussian noise   
Round-off noise is non-Gaussian. In order to add noise that adheres to a Gaussian (or other)

distribution, use Tools ⇒ Data Analysis. In the resulting dialog box, double-click on Random
Number Generation. Select Distribution: Normal, and click on the button to the left of Output
Range. Activate the input slot to its right, and either type N3:N10 or point to that range, and fi-
nally click OK. That will generate Gaussian noise (with zero mean value and unit standard de-
viation) in column N. In cell A1 place the label noise, and in cell A2 the value 0.2. Now modify
the instruction in cell B3 to =ROUND(10*C3/7,$A$14)+$A$2*N3, copy this instruction to cells
B4:B10, and repeat the analysis with LS0 and, if you wish, LS1. In the latter case you will again
find two slightly different answers, and you can decide for yourself whether the intercept a0 is
significantly larger than its standard deviation s0 so that it should be retained.

4. Use Solver 
There is yet another method to fit these data to a proportionality, a line, or whatever analytical

function that suits your fancy. It uses the non-linear least squares routine Solver and its comple-
ment, SolverAid. Here goes. 

In cells L1 and L15 place the label ycalc, in cells N12 and N16 the label a1=, in cells N13 and
N17 the label SSR=, and in cell N15 the label a0=. In cells O12, O15, and O16 deposit the value
1. Now place the instruction =$O$12*C3 in cell, and copy it down to row 10. Likewise place the
instruction =$O$15+$O$16*C17 in cell L17, and copy it down to row 24. In cell O13 deposit
=SUMXMY2(B3:B10,L3:L10), and =SUMXMY2(B17:B24,L17:L24) in cell O17. These latter
instructions compute the sum of squares of the differences between individual terms in the two
columns specified inside its brackets. The values 1 for a0 and a1 are initial guess values; you may
want to try other initial guess values as well. 

Now call Solver with Tools ⇒ Solver. In the dialog box that pops up enter Set Target Cell:
O13 (don’t worry about the auto-inserted dollar signs), Equal To: Min, By Changing Cells: O12,
then push Solve or OK, and answer OK to Keep Solver Solution. Solver has now changed the
value in cell O12 in order to minimize the value of the sum of squares in cell O13. Compare the
value so obtained for a1 in cell O12 with that found earlier in cell C11, and the values for ycalc in
columns D and L. All of these should be quite close if not identical. 

Solver does not provide standard deviations, but SolverAid does. Call SolverAid by clicking
on it on the MacroBundle toolbar (or with Alt∪F8 or Tools ⇒ Macro ⇒ Macros etc.) and answer
its input boxes: the parameters determined by Solver are located in O12, the sum of squares of
the residuals is located in O13, the column containing Ycalc is L3:L10. All these addresses can
be entered either by typing them, or by clicking on to the cell or range involved, in both cases
followed by pushing Enter. 

Repeat the same with the data in rows 17 through 24: call Solver, specify its target cell as
O17, to be minimized, by changing cells O15:O16. Then call SolverAid, specify the Solver pa-
rameters as O15:O16, the sum of squares of the residuals as in cell O17, and the column with
Ycalc as L17:L24, and instruct it to place the covariance matrix in, say, N19:O20. Compare
these results with those in B25:C30; again, they should be close. 


